#php8

  • Добрый день.Планируем переход на php версии 8.1. Скажите пожалуйста Webasyst и продукты разработанные Webasyst совместимы с этой версией? К примеру Shop-Script

  • Есть решение

    На установках (проверял на 3-х) с Магазином Инсталлер дает ошибку 500 на стенде с php 8.0.12. На установках без Магазина ошибки нет. Наборы плагинов и приложений везде разные, но из глобальных отличий только наличие/отсутствие Магазина.Ошибка такая...

    это строка "Plural-Forms: ..." в каком-то плагине/приложении старая, замените массово на во всех *.po файлах для русской локали на "Plural-Forms: nplurals=3; plural=((((n%10)==1)&&((n%100)!=11))?(0):(((((n%10)>=2)&&((n%10)<=4))&&(((n%100)<10)||((n%100)>=20)))?(1):2));\n"
    Anton Fedonyuk Anton F
  • +1 Исправлено

    Прошу подтвердить или опровергнуть ошибку при склейке (объединении) контактов в CRM последней версии c PHP 8.0.x.В той же самой конфигурации, но с PHP 7.2.x проблем нет. Все работает как часы.