Перестал работать wa()->getPlugin() после обновления

1

Перестал работать метод wa()->getPlugin() после последнего обновления.

Это критично, т.к. все плагины у меня используют для получения настроек такую конструкцию.

Проблемы возникают с приложениями сайт и мультиформы

Следущие конструкции не работают:

wa()->getPlugin('notice')
wa('multiform')->getPlugin('notice')
wa()->getPlugin('demos')
wa('site')->getPlugin('demo')

Например попытки выполнить функцию в кторой есть вызов wa()->getPlugin() возвращает ошибку 502

5 комментариев

  • +1
    Алексей Алексей Webasyst 8 декабря 2015 04:23 #

    502 это же ошибка Bad gateway
    Через приложение Разработка сейчас проверили
    print_r(wa('shop')->getPlugin('migrate'));

    PHP
    shopMigratePlugin Object
    (
        [id:protected] => migrate
        [app_id:protected] => shop
        [info:protected] => Array
            (
                [name] => Migrate to Shop-Script
                [description] => Transfer data from other ecommerce platforms to Shop-Script
                [img] => wa-apps/shop/plugins/migrate/img/migrate.png
                [vendor] => webasyst
                [version] => 2.1.0
                [importexport] => 1
                [handlers] => Array
                    (
                        [backend_welcome] => backendWelcomeHandler
                    )
    
                [id] => migrate
                [app_id] => shop
                [build] => 1449566534
            )
    
        [path:protected] => /var/www/ss6/wa-apps/shop/plugins/migrate
        [settings:protected] => 
        [settings_config:protected] => 
        [common_settings_config:protected] => Array
            (
            )
    
    )

    Ошибок нет.

    Добавить комментарий

    Чтобы добавить комментарий, зарегистрируйтесь или войдите