Установка Фремворка на ISPConfig Есть решение

При установке во время подключения к бд вылетает 500 ошибка.

Провал менять параметры разные параметры ничего не выходит.


Нашел в документации для Ngnix надо править конфиг. но не очень понял куда вставлять этот код из инструкции:


user www-data;

worker_processes 4;

pid /run/nginx.pid;

vents {

worker_connections 768;

# multi_accept on; }

http {

-------- }


4 ответа

  • 1
    Эрик Webasyst 20 ноября 2015 04:58 #

    Возможно, в смотрите не в ту инструкцию. Правильная инструкция - https://www.webasyst.ru/developers/docs/tips/nginx...

  • 1
    Sawer 20 ноября 2015 09:13 #

    Эту инструкцию я и видел. в теле вопроса приведен пример моего конфига NGiNX.

    Вопрос куда код из инструкции вставить в мой код ?


  • 1
    Sawer 21 ноября 2015 00:46 #

    Нашел куда вставлять код но при рестарте nginx ругается на код

    location /api.php {
    include
    /etc/nginx/fastcgi_params;
    fastcgi_pass
    127.0.0.1:9000;
    fastcgi_param SCRIPT_NAME
    /api.php;

    В чем проблема ?

    Если его закоменторовать все ок


  • 1
    Алексей Webasyst 21 ноября 2015 07:55 # Решение

    Вот файл с локально работающего сайта, /etc/nginx/sites-enabled/ss6

    server {
        listen   80; ## listen for ipv4; this line is default and implied
        listen   443 ssl;
    
        ssl_certificate     ss6.crt;
        ssl_certificate_key ss6.key;
    
        client_max_body_size 100m;
        root /var/www/ss6;
    
        try_files $uri $uri/ /index.php?$query_string;
        server_name ss6.local;
    
        index index.php;
    
        location /index.php {
            include fastcgi_params;
            fastcgi_pass  127.0.0.1:9000;
        }
    
        location /api.php {
            include /etc/nginx/fastcgi_params;
            fastcgi_pass  127.0.0.1:9000;
        }
    
        location ^~ /wa-data/protected/ {
            internal;
        }
        location ^~ /wa-data/protected/ {
            internal;
        }
    
        location ~* ^/wa-(log|config|cache|system)/ {
            return 403;
        }
    
        location ~* ^/wa-data/public/contacts/photo/[0-9]+/ {
             root /var/www/;
             access_log off;
             expires  30d;
             error_page   404  =  @contacts_thumb;
        }
    
        location @contacts_thumb {
            include fastcgi_params;
            fastcgi_pass  127.0.0.1:9000;
            fastcgi_param  SCRIPT_NAME  /wa-data/public/contacts/photo/thumb.php;
            fastcgi_param  SCRIPT_FILENAME  $document_root/wa-data/public/contacts/photo/thumb.php;
        }
    
        # shop app
        location ~* ^/wa-data/public/shop/products/[0-9]+/ {
            access_log   off;
            expires      30d;
        }
        location @shop_thumb {
            include fastcgi_params;
            fastcgi_pass  127.0.0.1:9000;
            fastcgi_param  SCRIPT_NAME  /wa-data/public/shop/products/thumb.php;
            fastcgi_param  SCRIPT_FILENAME  $document_root/wa-data/public/shop/products/thumb.php;
        }
        # end shop app
    
        location ~* ^.+\.(jpg|jpeg|gif|png|js|css)$ {
            access_log   off;
            expires      30d;
        }
    
        location ~ \.php$ {
            fastcgi_split_path_info ^(.+\.php)(/.+)$;
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_index index.php;
            include fastcgi_params;
            fastcgi_read_timeout 300;
        }
        location ~ /\.ht {
        deny all;
            }
    

    В nginx.conf location не прописывались. В нем по умолчанию указано:

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите