знак "=" в дополнительных параметрах Есть решение

Пытаюсь вывести через дополнительные параметры категории иконки fontawesome.

Вписываю icon=<i class="fa fa-heart"></i>

Но после сохранения категории сохраняется только все, что было до второго знака равно, в итоге остается:
icon=<i class
Можно как-то обойти это, чтобы этот второй знак = не обрабатывался и при сохранении ничего не отрубалось?

3 ответа

  • 3

    Как временное решение, пока разбираются с фреймворком, задавайте в значении дополнительного параметра не весь код, а только название класса. Ну и в шаблоне темы (или там где используется это значение) соответствующие изменения внести.

    • +1
      Максим Максим 7 ноября 2015 11:42 #

      да, видимо БАГ фреймворка...надеюсь разработчики внесут в план исправлений....

      Спасибо за решение, но оно немного не удобно, в плане того, что если нужно еще туда одну иконку загнать, то отдельный параметр нее придется создать и т.д и т.п...

      • +1
        Markus Markus 9 ноября 2015 03:03 #

        Записывайте параметр в виде

        icons=fa fa-heart,fa fa-hit,fa fa-sale

        В шаблоне проверяйте и выводите там где надо

        {if $product.params.icons}
        	{foreach from=explode(",",$product.params.icons) item=class}
        	<i class="{$class}"></i>
        	{/foreach}
        {/if}

        В итоге в коде получим

        <i class="fa fa-heart"></i>
        <i class="fa fa-hit"></i>
        <i class="fa fa-sale"></i>
        • +1
          Максим Максим 9 ноября 2015 06:47 #

          ДА, спасибо, но насколько проще была бы жизнь, если бы и в категориях нормально работало поле доп.параметров категории, так же как и на всех остальных страницах...

  • 1
    Алексей Webasyst 7 ноября 2015 09:34 #

    Например

    icon='<i class="fa fa-heart"></i>'
    • +1
      Максим Максим 7 ноября 2015 09:37 #

      К сожалению я пробовал и и одинарные и двойные кавычки, не помогает...получается все равно: icon='<i class

    • +2
      Максим Максим 7 ноября 2015 10:06 #

      При чем на всех других страницах где я ввожу такой доп.параметр, все норм, а вот когда задаю доп. параметр категории, он отрубается...

  • 1
    Михаил Ушенин Webasyst 9 ноября 2015 02:25 #

    Сообщение об ошибке передали разработчикам Shop-Script, спасибо!

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите