и снова про https Есть решение

Добрый день

Купил ssl сертификат, хочу чтобы весь сайт работал по защищенному протоколу (вроде как гугл это любит)

соответственно нужен редирект с http на https

Служба поддержки хостинга установила по моей просьбе, но после настройки редиректа сайт перестал открываться "циклическая переадресация"

Говорят что надо смотреть настройки сайта.

в данный момент галочка Использовать защищенное HTTPS-соединение при оформлении заказа и для личного кабинета покупателя снята (я так понимаю это только для корзины и лк)

В хтачес написано: (сейчас редирект отключен чтоб хоть как-то работало)

#RewriteEngine On

#RewriteCond %{HTTPS} off

#RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}


Вопрос: есть ли в движке какие-то настройки, которые могут привести к такому?

4 ответа

  • 1
    oleg - 25 сентября 2017 12:48 # Решение

    так. все кажется проще. исправил в настройках инсталлера путь и кажется работает!


  • 1
    Эрик Webasyst 21 октября 2015 04:27 #

    Вам нужно смотреть шаблоны дизайна в разделе Магазин / Витрина / Шаблоны. По всей видимости в них есть ссылки с явно указанным протоколом http, что и приводит к ошибкам. Нужно исправить такие ссылки на https.

    • +1
      oleg - oleg - 21 октября 2015 05:41 #

      я так понимаю что циклическая переадресация когда я при работе по https пытаюсь подгрузить часть контента с своего сайта по http ?

      или код в шаблоне

      <div itemscope itemtype="http://schema.org/Store">

      тоже может выдать ошибку?

      т.к. иначе я ничего не нахожу

      • +1

        Со своего сайта. Скрипты, css, изображения

        • +1
          oleg - oleg - 21 октября 2015 06:47 #

          ничего не могу найти...

          корректно ли открыть сайт по https и поискать в коде страницы http: ?

          сайт 8sezon.ru

          • +1
            Алексей Алексей Webasyst 21 октября 2015 07:47 #

            Обычно так и делают. Посмотрите статью https://support.webasyst.ru/forum/7350/obnaruzhen-...
            На сайте https://8sezon.ru все хорошо и предупреждений нет. Не считая предупреждений слабого алгоритма у яндекса, но на это повлиять не можем.

            • +1
              oleg - oleg - 21 октября 2015 08:01 #

              как только включаю редирект

              .htaccess

              <FilesMatch "\.md5$">
                  Deny from all
              </FilesMatch>
              
              DirectoryIndex index.php
              Options -Indexes
              # Comment the following line, if option Multiviews not allowed here
              Options -MultiViews
              
              AddDefaultCharset utf-8
              
              <ifModule mod_rewrite.c>
                  RewriteEngine On
                  # Uncomment the following line, if you are having trouble
                  #RewriteBase /
              
                  RewriteCond %{REQUEST_URI} !\.(js|css|jpg|jpeg|gif|png)$ [or]
                  RewriteCond %{REQUEST_URI} apple-touch-icon\.png$
                  RewriteCond %{REQUEST_FILENAME} !-f
                  RewriteCond %{REQUEST_FILENAME} !-d
                  RewriteRule ^(.*)$ index.php [L,QSA]
              </ifModule>
              
              <ifModule mod_headers.c>
                  <FilesMatch "\.(jpg|jpeg|png|gif|js|css)$">
              	Header set Cache-Control "max-age=3153600, public"
                  </FilesMatch>
              </ifModule>
              
              
              
              
              RewriteEngine On 
              RewriteCond %{HTTPS} off 
              RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}  

              и пытаюсь зайти скажем на https://8sezon.ru/2301/

              меня перебрасывает на https://8sezon.ru/index.php с сообщением о большом количестве переадресаций

              вот что в заголовках


              https://8sezon.ru/2301/
              
              GET /2301/ HTTP/1.1
              Host: 8sezon.ru
              User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:41.0) Gecko/20100101 Firefox/41.0
              Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
              Accept-Language: ru-RU,ru;q=0.8,en-US;q=0.5,en;q=0.3
              Accept-Encoding: gzip, deflate
              Cookie: __utma=56247266.1139659575.1434000249.1445422640.1445426521.13; __utmz=56247266.1442386569.8.2.utmcsr=google|utmccn=termopr2|utmcmd=cpc; jv_visits_count_T5DHRgm9PR=9; shop_lastview=4%2C18; geoip_not_first=1; landing=%2F; PHPSESSID=soqe34hbbqonrskn55p9f611c1; jv_enter_ts_T5DHRgm9PR=1445416982618; jv_gui_state_T5DHRgm9PR=WIDGET; dinfo_country=rus; dinfo_city=%D0%9D%D0%BE%D0%B2%D0%BE%D1%81%D0%B8%D0%B1%D0%B8%D1%80%D1%81%D0%BA; dinfo_region=54; dinfo_region_name=%D0%9D%D0%BE%D0%B2%D0%BE%D1%81%D0%B8%D0%B1%D0%B8%D1%80%D1%81%D0%BA%D0%B0%D1%8F+%D0%BE%D0%B1%D0%BB%D0%B0%D1%81%D1%82%D1%8C; dinfo_district=%D0%A1%D0%B8%D0%B1%D0%B8%D1%80%D1%81%D0%BA%D0%B8%D0%B9+%D1%84%D0%B5%D0%B4%D0%B5%D1%80%D0%B0%D0%BB%D1%8C%D0%BD%D1%8B%D0%B9+%D0%BE%D0%BA%D1%80%D1%83%D0%B3; __utmc=56247266
              Connection: keep-alive
              
              HTTP/1.1 302 Found
              Server: nginx
              Date: Wed, 21 Oct 2015 11:56:30 GMT
              Content-Type: text/html; charset=iso-8859-1
              Content-Length: 289
              Connection: keep-alive
              Location: https://8sezon.ru/index.php
              
              • 0
                Эрик Эрик Webasyst 21 октября 2015 08:50 #

                Вот если сейчас открыть страницу https://8sezon.ru/2301/ и посмотреть в ее исходный код, то поиском по запросу "http:" находится 9 совпадений. Именно их и нужно устранить (заменить на https или сделать ссылки относительными).

  • 1

    Циклическая переадресация не имеет отношения к контенту сайта.

    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

    И как написано тут

    https://support.webasyst.ru/forum/4293/kak-praviln...

    Редирект на https следует делать первым (после RewriteEngine On и #RewriteBase /)

    • +1
      oleg - oleg - 21 октября 2015 12:51 #

      Вот так сделал, не помогло

      <FilesMatch "\.md5$">
          Deny from all
      </FilesMatch>
      
      DirectoryIndex index.php
      Options -Indexes
      # Comment the following line, if option Multiviews not allowed here
      Options -MultiViews
      
      AddDefaultCharset utf-8
      
      <ifModule mod_rewrite.c>
          RewriteEngine On
          # Uncomment the following line, if you are having trouble
          #RewriteBase /
      RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
      
          RewriteCond %{REQUEST_URI} !\.(js|css|jpg|jpeg|gif|png)$ [or]
          RewriteCond %{REQUEST_URI} apple-touch-icon\.png$
          RewriteCond %{REQUEST_FILENAME} !-f
          RewriteCond %{REQUEST_FILENAME} !-d
          RewriteRule ^(.*)$ index.php [L,QSA]
      </ifModule>
      
      <ifModule mod_headers.c>
          <FilesMatch "\.(jpg|jpeg|png|gif|js|css)$">
      	Header set Cache-Control "max-age=3153600, public"
          </FilesMatch>
      </ifModule>
      
      
      
      
      #RewriteEngine On 
      #RewriteCond %{HTTPS} off 
      #RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}  
      • +1

        А RewriteCond %{HTTPS} off куда дели? :)


        <FilesMatch "\.md5$">
            Deny from all
        </FilesMatch>
        
        DirectoryIndex index.php
        Options -Indexes
        # Comment the following line, if option Multiviews not allowed here
        Options -MultiViews
        
        AddDefaultCharset utf-8
        
        <ifModule mod_rewrite.c>
            RewriteEngine On
            # Uncomment the following line, if you are having trouble
            #RewriteBase /
            RewriteCond %{HTTPS} off 
            RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
        
            RewriteCond %{REQUEST_URI} !\.(js|css|jpg|jpeg|gif|png)$ [or]
            RewriteCond %{REQUEST_URI} apple-touch-icon\.png$
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteRule ^(.*)$ index.php [L,QSA]
        </ifModule>
        
        <ifModule mod_headers.c>
            <FilesMatch "\.(jpg|jpeg|png|gif|js|css)$">
                Header set Cache-Control "max-age=3153600, public"
            </FilesMatch>
        </ifModule>
        


        • +1
          oleg - oleg - 21 октября 2015 13:49 #

          так тоже не робит


          <FilesMatch "\.md5$">
              Deny from all
          </FilesMatch>
          
          DirectoryIndex index.php
          Options -Indexes
          # Comment the following line, if option Multiviews not allowed here
          Options -MultiViews
          
          AddDefaultCharset utf-8
          
          <ifModule mod_rewrite.c>
              RewriteEngine On
              # Uncomment the following line, if you are having trouble
              #RewriteBase /
          RewriteCond %{HTTPS} off 
          RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
          
              RewriteCond %{REQUEST_URI} !\.(js|css|jpg|jpeg|gif|png)$ [or]
              RewriteCond %{REQUEST_URI} apple-touch-icon\.png$
              RewriteCond %{REQUEST_FILENAME} !-f
              RewriteCond %{REQUEST_FILENAME} !-d
              RewriteRule ^(.*)$ index.php [L,QSA]
          </ifModule>
          
          <ifModule mod_headers.c>
              <FilesMatch "\.(jpg|jpeg|png|gif|js|css)$">
          	Header set Cache-Control "max-age=3153600, public"
              </FilesMatch>
          </ifModule>
          
          
          
          
          #RewriteEngine On 
          #RewriteCond %{HTTPS} off 
          #RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}  
          • +1

            Циклическая переадресация? Тогда попробуйте очистить кэш перед тем как проверить снова.

            У меня на тестовой установке такой вариант работает.

        • +1
          Александр Сергеевич Александр Сергеевич 23 октября 2015 15:17 #

          Такая же проблема. Возникает цикличная ссылка или "ERR_TOO_MANY_REDIRECTS". Причём, если при вводе адреса сайта вручную написать https, то всё работает на ура.

  • 1
    NskRonin 7 февраля 2016 05:40 #

    Мне помогло вот это:

    RewriteCond %{HTTP:X-SSL} !^yes$
    RewriteRule (.*) https://yourdomain.com/https://yourdomain.com/$1 [R=301,L]

    Общий вид моего .htaccess

    <FilesMatch "\.md5$">
        Deny from all
    </FilesMatch>
    
    DirectoryIndex index.php
    Options -Indexes
    # Comment the following line, if option Multiviews not allowed here
    Options -MultiViews
    
    AddDefaultCharset utf-8
    
    <ifModule mod_rewrite.c>
        RewriteEngine On
        # Uncomment the following line, if you are having trouble
        #RewriteBase /
    	RewriteCond %{HTTP:X-SSL} !^yes$
    	RewriteRule (.*) https://kd54.ru/$1 [R=301,L]
    	
        RewriteCond %{REQUEST_URI} !\.(js|css|jpg|jpeg|gif|png)$ [or]
        RewriteCond %{REQUEST_URI} apple-touch-icon\.png$
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ index.php [L,QSA]
    </ifModule>
    
    <ifModule mod_headers.c>
        <FilesMatch "\.(jpg|jpeg|png|gif|js|css)$">
    	Header set Cache-Control "max-age=3153600, public"
        </FilesMatch>
    </ifModule>
    • +1
      oleg - oleg - 25 сентября 2017 12:23 #

      наконец то пришло время вернуться к вопросу. )) ну так сайт открывается по http://kd54.ru редиекта на https то нет

      • +1
        NskRonin NskRonin 25 сентября 2017 16:09 #

        Согласен. Пришлось изменить htaccess, т.к. у сайт есть поддомен.

        Но скрипт выше - рабочий. Вот сайт с редиректом https://vikante.ru/

        • +1
          oleg - oleg - 25 сентября 2017 20:38 #

          у меня так только завелось


          RewriteEngine On
          RewriteCond %{HTTPS} off
          RewriteCond %{HTTP:X-Forwarded-Proto} !https
          RewriteCond %{REQUEST_URI} !robots.txt
          RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите