6 ответов

  • 1
    Rat Партнер-разработчик 4 сентября 2021 06:32 #

    Скорее всего, должен работать, кроме каких-то совсем редких сценариев, потому что в обновлениях время от времени улучшают поддержку PHP 8.

  • 1
    ВЕтал 4 сентября 2021 06:38 #

    Включаю php8 на сервере, сайт падает но админка работает не вся, например инсталер не работает.

    ошибка сайта: 

    Fatal error: Array and string offset access syntax with curly braces is no longer supported in /home/xxxxxx/domains/мойдомен.ru/public_html/wa-apps/shop/plugins/regions/lib/vendor/sxgeo/shopRegionsSxGeo.class.php on line 217

    ошибка инсталера:

    Fatal error: Unparenthesized `a ? b : c ? d : e` is not supported. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)` in /home/xxxxxx/domains/мойдомен.ru/public_html/wa-system/helper/misc.php(116) : eval()'d code on line 1

    Версия Вебасиста 2.2.1.613
    Версия Shop-Script 8.21.0.49
  • 2

    чистый SS  работает, плагины требуют напильника, многие.

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите