За что отвечают вот эти папки

Добрый день! Скажите за что отвечает каждая из ниже перечисленных папок?

1. wa-cache

2. wa-config

3. wa-content

4. wa-installer

5. wa-log

6. wa-sources

7. wa-apps

9. wa-data

10. wa-plugins

11. wa-system

9 ответов

  • 1
    1. Кеш.
    2. Конфигурационные файлы.
    3. Общие JavaScript-, CSS- и графические файлы фреймворка.
    4. Установщик.
    5. Логи.
    6. Архивы с исходным кодом, используемые установщиком.
    7. Исходный код приложений, плагинов к ним и тем дизайна.
    8. Файлы данных, используемые приложениями и и плагинами к ним.
    9. Системные плагины фреймворка.
    10. Системные файлы фреймворка.

    А вам зачем?

    * У вас сбилась нумерация пунктов.

    • +1
      АР АР 11 мая 2015 15:04 #

      Если очень коротко, но лаконично, то вот примерно зачем:

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Хочу заметить, что я всё делал в первый раз как ученик в первом классе. Целый месяц я работал на локальном сервере, на днях заливал свои сайт на хостинг без архива, весом примерно 480МБ. Не передалось примерно 80 файлов. В результате чего на хостинге я не смог зайти в административную часть сайта, точнее вообще ничего не смог сделать кроме как полюбоваться что файлы там есть.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Но самое удивительное на моём локальном сервере у меня тоже всё перестало всё работать.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Я вообще не понимаю, каким образом были затронуты файлы на локальном сервере?<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Мне удалось восстановить всё простым образом. Я заново установил фреимворк в новую папку и заново создал новую базу данных. После чего заменил во вреимворке папку «wa-data».<o:p></o:p>

      И о чудо ву аля всё заработало. Всё, кроме того, что я не смог зайти на сайт как посетитель (покупатель) а только мог работать в административной части. По структуре сайта как я понимаю вход в магазин вот такой: localhost/webasyst/shop/* .<o:p></o:p>

      А я когда создавал новую базу данных и называл папку для фреимврка назвал её другим именем а не webasyst.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Вот я и решил, что именно поэтому я не могу зайти как посетитель на сайт.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">После чего не долго думая я решил это исправить, предварительно скопировав на другой диск всю папку с работающим фремворком, но без базы данных.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">И заново создал папку по имени webasyst и установил в неё фреимворк потом также как и в первый раз заменил папку «wa-data».<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">И к моему великому разочарованию на это раз ничего хорошего не произошло. Денвер выдал ошибку что толи нет такого пути, толи нет такой базы.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Специалисты говорят что мол это всё из-за того что я удалил старую базу маскюль.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">А я вот и думая, но ведь первый раз когда у меня всё получилось, я ведь тоже создал совершенно новую базу маскюль и новую папку с фрейворком. И всё было Гуд.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Так почему же во второй раз когда я проделал тоже самое ничего не получилось, причём тут старая база маскюль?<o:p></o:p>

      Вот если коротко примерно так Михаил! Надеюсь я вас не запутал. Спасибо за ваши ответы!

      • +1
        АР АР 11 мая 2015 15:06 #

        Если очень коротко, но лаконично, то вот примерно зачем:

        Хочу заметить, что я всё делал в первый раз как ученик в первом классе. Целый месяц я работал на локальном сервере, на днях заливал свои сайт на хостинг без архива, весом примерно 480МБ. Не передалось примерно 80 файлов. В результате чего на хостинге я не смог зайти в административную часть сайта, точнее вообще ничего не смог сделать кроме как полюбоваться что файлы там есть.<o:p></o:p>

        Но самое удивительное на моём локальном сервере у меня тоже всё перестало всё работать.<o:p></o:p>

        Я вообще не понимаю, каким образом были затронуты файлы на локальном сервере?<o:p></o:p>

        Мне удалось восстановить всё простым образом. Я заново установил фреимворк в новую папку и заново создал новую базу данных. После чего заменил во вреимворке папку «wa-data».<o:p></o:p>

        И о чудо ву аля всё заработало. Всё, кроме того, что я не смог зайти на сайт как посетитель (покупатель) а только мог работать в административной части. По структуре сайта как я понимаю вход в магазин вот такой: localhost/webasyst/shop/* .<o:p></o:p>

        А я когда создавал новую базу данных и называл папку для фреимврка назвал её другим именем а не webasyst.<o:p></o:p>

        Вот я и решил, что именно поэтому я не могу зайти как посетитель на сайт.<o:p></o:p>

        После чего не долго думая я решил это исправить, предварительно скопировав на другой диск всю папку с работающим фремворком, но без базы данных.<o:p></o:p>

        И заново создал папку по имени webasyst и установил в неё фреимворк потом также как и в первый раз заменил папку «wa-data».<o:p></o:p>

        И к моему великому разочарованию на это раз ничего хорошего не произошло. Денвер выдал ошибку что толи нет такого пути, толи нет такой базы.<o:p></o:p>

        Специалисты говорят что мол это всё из-за того что я удалил старую базу маскюль.<o:p></o:p>

        А я вот и думая, но ведь первый раз когда у меня всё получилось, я ведь тоже создал совершенно новую базу маскюль и новую папку с фрейворком. И всё было Гуд.<o:p></o:p>

        Так почему же во второй раз когда я проделал тоже самое ничего не получилось, причём тут старая база маскюль?<o:p></o:p>

        Вот если коротко примерно так Михаил! Надеюсь я вас не запутал. Спасибо за ваши ответы!

        • +1

          Вот с этого и нужно было сразу начинать :)

          По поводу папок и базы данных: удалять ничего не нужно, если вы не понимаете, к чему это приведёт. И перед удалением лучше сначала сохранить резервную копию то, что собираетесь удалить.

          Что-то большее из вашего рассказа я вряд ли смогу понять — нужны конкретные сообщения об ошибках и подробный рассказ, что и для чего вы делали.

    • +1
      АР АР 11 мая 2015 15:04 #

      Если очень коротко, но лаконично, то вот примерно зачем:

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Хочу заметить, что я всё делал в первый раз как ученик в первом классе. Целый месяц я работал на локальном сервере, на днях заливал свои сайт на хостинг без архива, весом примерно 480МБ. Не передалось примерно 80 файлов. В результате чего на хостинге я не смог зайти в административную часть сайта, точнее вообще ничего не смог сделать кроме как полюбоваться что файлы там есть.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Но самое удивительное на моём локальном сервере у меня тоже всё перестало всё работать.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Я вообще не понимаю, каким образом были затронуты файлы на локальном сервере?<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Мне удалось восстановить всё простым образом. Я заново установил фреимворк в новую папку и заново создал новую базу данных. После чего заменил во вреимворке папку «wa-data».<o:p></o:p>

      И о чудо ву аля всё заработало. Всё, кроме того, что я не смог зайти на сайт как посетитель (покупатель) а только мог работать в административной части. По структуре сайта как я понимаю вход в магазин вот такой: localhost/webasyst/shop/* .<o:p></o:p>

      А я когда создавал новую базу данных и называл папку для фреимврка назвал её другим именем а не webasyst.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Вот я и решил, что именно поэтому я не могу зайти как посетитель на сайт.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">После чего не долго думая я решил это исправить, предварительно скопировав на другой диск всю папку с работающим фремворком, но без базы данных.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">И заново создал папку по имени webasyst и установил в неё фреимворк потом также как и в первый раз заменил папку «wa-data».<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">И к моему великому разочарованию на это раз ничего хорошего не произошло. Денвер выдал ошибку что толи нет такого пути, толи нет такой базы.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Специалисты говорят что мол это всё из-за того что я удалил старую базу маскюль.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">А я вот и думая, но ведь первый раз когда у меня всё получилось, я ведь тоже создал совершенно новую базу маскюль и новую папку с фрейворком. И всё было Гуд.<o:p></o:p>

      <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Так почему же во второй раз когда я проделал тоже самое ничего не получилось, причём тут старая база маскюль?<o:p></o:p>

      Вот если коротко примерно так Михаил! Надеюсь я вас не запутал. Спасибо за ваши ответы!

  • 1
    АР 12 мая 2015 04:07 #

    Расскажу всё по порядку:

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">1.<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Я загрузил свои файлы с локального севера на хостинг при помощи программы FileZilla. При передаче данных не передалось всего 84 файла из 700 тысяч.<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">После чего я теперь не могу зайти в панель администратора сайта как на локальном сервере так и на хостинге , точнее я вообще не могу никуда войти.<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Я вообще не понимаю каким образом были затронуты файлы на локальном сервере?<o:p></o:p>

    1. 1 При попытке входа в панель администратора на локальном сервере Денвер http://localhost/webasyst/webasyst/<o:p></o:p><o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">выводится вот такое сообщение:<o:p></o:p>

    Внимание : require_once (Z: \ главная \ \ WWW LOCALHOST \ WebAsyst \ WA-Apps \ Контакты \ Lib / модели / contactsRights.model.php) [ function.require однократной ]: не удалось не удалось открыть поток: Нет такого файла или каталога в Z: \ главная \ локального хоста \ WWW \ WebAsyst \ ва-система \ помощником \ view.php на линии 101

    Фатальная ошибка : require_once () [ function.require ]: Сбой открытия требуется 'Z: \ главная \ локального хоста \ WWW \ WebAsyst \ WA-приложения \ Контакты \ Lib / модели / contactsRights.model.php "(include_path = '.; C: \ PHP \ груши») в Z: \ главная \ \ WWW локального хоста \ WebAsyst \ ва-системы \ вспомогательный \ вид. PHP на линии 101<o:p></o:p><o:p></o:p>

    1. 2 При попытке входа на страницу сайт как пользователь (покупатель) на локальном сервереhttp://localhost/webasyst/shop/<o:p></o:p><o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">выводится вот такое сообщение:

    • +2

      Думаю, что нужно было изначально решить вот эту проблему:

      >>> При передаче данных не передалось всего 84 файла из 700 тысяч.

  • 1
    АР 12 мая 2015 04:07 #

    Расскажу всё по порядку:

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">1.<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Я загрузил свои файлы с локального севера на хостинг при помощи программы FileZilla. При передаче данных не передалось всего 84 файла из 700 тысяч.<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">После чего я теперь не могу зайти в панель администратора сайта как на локальном сервере так и на хостинге , точнее я вообще не могу никуда войти.<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Я вообще не понимаю каким образом были затронуты файлы на локальном сервере?<o:p></o:p>

    1. 1 При попытке входа в панель администратора на локальном сервере Денвер http://localhost/webasyst/webasyst/<o:p></o:p><o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">выводится вот такое сообщение:<o:p></o:p>

    Внимание : require_once (Z: \ главная \ \ WWW LOCALHOST \ WebAsyst \ WA-Apps \ Контакты \ Lib / модели / contactsRights.model.php) [ function.require однократной ]: не удалось не удалось открыть поток: Нет такого файла или каталога в Z: \ главная \ локального хоста \ WWW \ WebAsyst \ ва-система \ помощником \ view.php на линии 101

    Фатальная ошибка : require_once () [ function.require ]: Сбой открытия требуется 'Z: \ главная \ локального хоста \ WWW \ WebAsyst \ WA-приложения \ Контакты \ Lib / модели / contactsRights.model.php "(include_path = '.; C: \ PHP \ груши») в Z: \ главная \ \ WWW локального хоста \ WebAsyst \ ва-системы \ вспомогательный \ вид. PHP на линии 101<o:p></o:p><o:p></o:p>

    1. 2 При попытке входа на страницу сайт как пользователь (покупатель) на локальном сервереhttp://localhost/webasyst/shop/<o:p></o:p><o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">выводится вот такое сообщение:

  • 1
    АР 12 мая 2015 04:08 #

    Ошибка # 0<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Применение "магазин" не существует.<o:p></o:p><o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Пожалуйста, обратитесь к администратору сервера.<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">1. 3 При попытке входа в панель администратора сайта на хостинге:<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">выводится вот такое сообщение:<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Ошибка # 1045<o:p></o:p><o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:13.6pt;margin-left: 0cm;line-height:14.55pt">Не отказано в доступе для пользователя 'root'@'10.2.1.16 "(с помощью пароля: НЕТ)<o:p></o:p><o:p></o:p>

    Пожалуйста, обратитесь к администратору сервера.

  • 1
    АР 12 мая 2015 04:08 #

    2. Проблемы описанные в пунктах 1.1 и 1.2 была связана с папкой «wa-system».

    я её устранил следующим образом:<o:p></o:p>

    2. 1 Просто создал новую папку «kuramba.ru2» и установил в неё Фраимворк заново. <o:p></o:p>

    2.2 Затем из своих наработок скопировал папку «wa-data» во вновь установленный фраимворк (пака «kuramba.ru2») . В наработках я полностью сделал каталог товаров, частично загрузи примерно 150 товаров с описанием и рисунками, настроил фотоальбом, создал новые страницы и так далее.<o:p></o:p>

    2.3 Папку «wa-system» которая была причиной сбоя я менять не стал. Заменял лия другие папки я к сожалению не помню. <o:p></o:p>

    2.4 Потом обновил в инсаталере купленные продукты (лицензию, тему дизайн со вкусом 2, и плагин не обрезая изображения). И всё заработало. Единственное что не работало это то что я не мог войти на сайт как пользователь (покупатель). <o:p></o:p>

    При попытке входа на страницу сайт как пользователь (покупатель) на локальном сервере:<o:p></o:p>

    Ошибка #0<o:p></o:p>

    Application "shop" does not exist.<o:p></o:p>

    Please contact server administrator.<o:p></o:p>

    2.5 И поэтому я начал делать всё заново.<o:p></o:p>

    У меня было такое мнение что я не мог войти на сайт как посетитель (то есть эта страница не работала) из-за того что новую папку в которую устанавливался Фреймворк я назвал «kuramba.ru2» а не «webasyst». А по структуре сайта как я понимаю вход в магазин вот такой: localhost/webasyst/shop/*

  • 1
    АР 12 мая 2015 04:09 #

    3. Я снова заново установил фраимворк в паку под названием «webasyst»

    3.1 затем снова заменил папку «wa-data»<o:p></o:p>

    3.2 Затем обновление через инсталлер купленных продуктов.<o:p></o:p>

    Но к сожалению в этот раз даже после того как я вставил папку «wa-data» ничего не произошло. Точнее в панели администрировании не отражаются мои наработки.<o:p></o:p>

    3.3 Поэтому я решил заменить остальные папки кроме одной («wa-system») из-за которой точно помню у меня были проблемы описанные в пунктах 1,1 и 1.2.<o:p></o:p>

    3.4 Так вот после замены остальных папок опять всё перестаёт работать. Высвечивается ошибка. Какая я не могу сказать потому что не хочу всё снова испортить.<o:p></o:p>

    В общем если коротко сейчас всё работает, но без моих наработок. <o:p></o:p>

    ВОПРОСЫ:<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:0cm;margin-left:36.0pt; margin-bottom:.0001pt;text-indent:-18.0pt;line-height:14.55pt;mso-list:l0 level1 lfo1; tab-stops:list 36.0pt"><!--[if !supportLists]-->1. <!--[endif]-->Вот я и хочу узнать какие папки за что отвечают в фрамворке?<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:0cm;margin-left:36.0pt; margin-bottom:.0001pt;text-indent:-18.0pt;line-height:14.55pt;mso-list:l0 level1 lfo1; tab-stops:list 36.0pt"><!--[if !supportLists]-->2. <!--[endif]-->И какие папки возможно являются причиной нового сбоя ?<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:0cm;margin-left:36.0pt; margin-bottom:.0001pt;text-indent:-18.0pt;line-height:14.55pt;mso-list:l0 level1 lfo1; tab-stops:list 36.0pt"><!--[if !supportLists]-->3. <!--[endif]-->И самое главное помогите мне вернуть мой сайт с моими наработками?<o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:0cm;margin-left:18.0pt; margin-bottom:.0001pt;line-height:14.55pt">Как я уже сказал раньше я заменил папку «wa-data» со своими старыми наработками. <o:p></o:p>

    <p style="margin-top:0cm;margin-right:0cm;margin-bottom:0cm;margin-left:18.0pt; margin-bottom:.0001pt;line-height:14.55pt">Но только в этот раз мои наработки, почему то, не отображаются.<o:p></o:p>

    4. Вот я и хочу узнать в чём причина? Ведь первый раз когда я установил фраимворк в папку «kuramba.ru2» всё работало, за исключение того что я немог войти только на свой сайт как пользователь (посетитель).

  • 1
    АР 12 мая 2015 04:10 #

    Подскажите что мне делать???? Я можно сказать в ужасе, расстроен очень, работал на локалке месяц. И тут бац и не фига нет. Но я посмотрел вес папки с движком (сайтом) не изменился. Так что у меня есть надежда всё восстановить.

  • 1
    АР 12 мая 2015 04:10 #

    СПАСИБО!!!

  • 1
    АР 12 мая 2015 12:08 #

    Я это сам тоже понимаю, про 84 файла. Так я сразу и начал обращаться. Для меня загадка, что произошло с этими файлами на локальном сервере. Я вот собственно и спрашиваю совета. И самое главное как это решить?

    И если опять повторить мою проблему и очень коротко:

    То ведь первый раз у меня всё удалось сделать несмотря на отсутствие этих потерянных 84х файлов.

    И несмотря на то что я сейчас в этом разбираюсь как малыш в группе детского сада в Ясельках разбирается в ядерной физике, или не знаю в интегральных выражениях. :)

    • +1

      Подозреваю, что в вашем случае имела место неаккуратность, которая часто имеет место, когда обращаешься с чем-то новым. Иначе говоря, вам пока не хватает опыта в создании сайтов, по крайней мере, с использованием Вебасиста — это неприятно, но поправимо. Каким бы удобным ни был инструмент, для обращения с ним всё равно требуется хоть какая-то минимальная квалификация, а она приходит с опытом. Скорее всего, я пишу бесполезные в конкретной ситуации банальности, но чем-то практически помочь вам вряд ли кто-то сможет, разве только придя к вам домой и посмотрев, где какие файлы у вас находятся и что именно содержится в вашей базе данных. Предложить могу пока только одно из двух: либо начать всё с начала, время от времени сохраняя копию созданного вами материала, чтобы восстановить в случае поломки, либо поискать специалиста, который за деньги сделает вам то, что нужно, и заодно научит обращению со скриптами.

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите