Не могу войти в панель администратора на локальном сервере Денвер

Доброго времени суток! 2 апреля я скачал и установил денвер для создания сайта. Проработав больше месяца, всё было успешно, сегодня я залиливал движок с локального сервера на хостинг при помощи программы FileZilla. После чего я теперь не могу зайти в панель администратора, точнее я вообще не могу никуда войти.

Вот выдаётся такое сообщение:

Warning: require_once(Z:\home\loca<wbr style="display: inline-block;">lhost\www\webasyst\wa-app<wbr style="display: inline-block;">s\contacts\lib/models/con<wbr style="display: inline-block;">tactsRights.model.php) [function.require-once]: failed to open stream: No such file or directory inZ:\home\localhost\www\web<wbr style="display: inline-block;">asyst\wa-system\helper\vi<wbr style="display: inline-block;">ew.php on line 101

Fatal error: require_once() [function.require]: Failed opening required 'Z:\home\localhost\www\we<wbr style="display: inline-block;">basyst\wa-apps\contacts\l<wbr style="display: inline-block;">ib/models/contactsRights.<wbr style="display: inline-block;">model.php' (include_path='.;C:\php\p<wbr style="display: inline-block;">ear') inZ:\home\localhost\www\web<wbr style="display: inline-block;">asyst\wa-system\helper\vi<wbr style="display: inline-block;">ew.php on line 101

А при входе в магазин как пользователь (посетитель сайта) тоже на локальном сервере высвечивается вот такое сообщение:

<h1 style="margin-top: 30px; margin-bottom: 7px; font-size: 2.5em; font-family: Arial, sans-serif; line-height: 1.2em; font-weight: normal; max-height: 50px; text-align: center;">Ошибка #0</h1><h2 style="margin-bottom: 15px; font-size: 1.35em; line-height: 1.2em; color: red; text-align: center;">Application "shop" does not exist.</h2>

Please contact server administrator.

Что мне сделать как исправить это что бы всё заработало снова ?

2 ответа

  • 1
    Алексей Webasyst 15 мая 2015 10:21 #

    У вас лишний код в тексте <wbr style="display: inline-block;">.

    Сообщение "Application "shop" does not exist." - у вас не установлено приложение Shop-script или отсутствуют основные файлы. Если на хостинге все работает, то можете с него скопировать все обратно на локальную установку.

  • 1
    АР 15 мая 2015 12:42 #

    Спасибо Алексей за ваш ответ!

    На настоящий момент мне удалось всё восстановить при помощи специалистов из Центра заказчика Вебасит (за исключением некоторых настроек).

    Проблема была в конфигурационном файле wa-config/db.php.

    Они мне его исправили.

    А теперь кратко, немного из моей истории:

    Четырьмя днями ранее у меня перестало всё работать, как на хостинге и на локалке. И всё из-за того, что на хостинг с локального сервера не передалось 84 файла. Но суть в том каким образом передача файлов при помощи Фаил зилллы повлияла на локальный сервер ума не приложу

    ВОПРСЫ:

    Но теперь у меня ещё одна проблема.

    Дело в том что сейчас база данных на хостинге у меня называется одним именем, на моём локальном севере другим.

    И вот теперь чтобы у меня на локальном сервере всё заработало мне надо применить базу данных с локального сервера и поменять имя в ней (применить имя базы данных на локальном сервере).

    А как это сделать я не знаю.

    Мне сказали что надо поменять данные в конфигурационном файле wa-config/db.php

    А как это сделать, что там менять, где и как я не знаю? Да и чем открыть данный файл тоже не знаю?

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите