Ошибка при переходе на PHP 7.2 и выше Не принято

2

Сегодня хостер пытался изменить по нашей просьбе версию PHP на 7.2 или более высокую, и ничего не получилось.

Вот ответ от хостера

При версии php 7.2 и выше на сайте возникает ошибка 500.
~$ curl -IL мойсайт.ru
HTTP/1.1 500 Internal Server Error
Server: nginx/1.17.9
Date: Thu, 02 Apr 2020 20:18:21 GMT
Content-Type: text/html; charset=utf-8
Content-Length: 366979
Connection: keep-alive
Last-Modified: Tue, 31 Mar 2020 12:23:40 GMT
ETag: «14005d5e-59983-5a225a34972c2»
Accept-Ranges: bytes
Рекомендуем обратиться к разработчикам сайта по вопросу работы сайта на версии php выше 7.1.

Кто знает что с этим делать?  Как исправить?

4 комментария

  • +1

    В настройках приложения «Логи» включите логирование ошибок PHP, снова попытайтесь открыть сайт и посмотрите, какие записи появятся в лог-файле php.log в случае повторения ошибки.

  • +1
    Roman - Roman - 5 апреля 2020 23:32 #

    Логирование ошибок PHP включил, версию PHP менял, сайт открывал. Но файл php.log не появился

    • +1

      Тогда надо обращаться в поддержку хостинга, чтобы рассказали подробности ошибки 500. Просто код 500 ни о чём конкретно не говорит.

      • +1
        Roman - Roman - 8 апреля 2020 12:42 #

        Спасибо за помощь! Хостер сам что-то поправил и все заработало)

        Добавить комментарий

        Чтобы добавить комментарий, зарегистрируйтесь или войдите