Сильно тормозит админка Есть решение

Добрый всем денечек. Такая проблема:

Под моим логином очень сильно тормозит сайт, не менее 30 секунд страница грузится, админка так же тормозит и не все картинки отображаются и эскизы тоже не подгружаются (на сайте, в админке видны все картинки). Под другим админом, то же самое, пробовал вообще создать нового пользователя и под ним те же проблемы. Если войти на сайт под новым (незарегистрированным) пользователем, страницы грузятся нормально, быстро, после таких тормозов, мне кажется, что страничка грузится даже немного быстрее, чем я кликаю на ссылку. Есть бекап на 30.01.2020 года, но боюсь с него восстанавливать, тк в январе сайт был на домене третьего уровня на wasist.rsfix.ru, а на rsfix.ru был старый сайт, теперь все наоборот. Есть бекап базы sql и есть полный каталог rsfix.ru, а в нем папка wp-admin, может только ее заменить на хостинге? Но, опять же, сомнения - ведь 30.01.2020 сайт был еще на wasist.rsfix.ru, получается, что у меня все ссылки поменяются. Или все будет нормально? Что вообще делать с такими тормозами? Кеши всех браузеров и системы чистил сто раз

4 ответа

  • 1
    Владимир Захаров 12 февраля 2020 14:38 # Решение

    Всем, кто пытался помочь, спасибо. Дело было в плагине "Управление плагинами". Интересно то, что это не новая установка, этот плагин я ставил давно, одним из первых и использовал его когда-то довольно часто. Сегодня отключил все плагины через Инсталлер (это все, что связанно с Магазин у меня тормозило, приложение Инсталлер работало нормально), а потом по одному включал. И вот, когда подключил "Управление плагинами", опять начался вчерашний козлицизм. Опять отключил, все заработало нормально. Удалил вообще этот плагин, естественно, ничего не тормозит, снова установил, пока нормально, но только запустил этот плагин, опять тормоза, сейчас удалил и снова все нормально. 

    Об этом плагине отзывы только положительные, ни одной подобной жалобы в отзывах. Наверно, у меня он с чем-то конфликтует, а может, и вообще, дело во мне. Придется обходиться без этого плагина, зато все отлично работает 

  • 1
    Владимир Захаров 11 февраля 2020 14:03 #

    Неужели это совсем новая проблема?! У меня первого начала тормозить админка и сайт под зарегистрированными пользователями? Где эксперты и просто люди?! Да, забыл, тема у меня Unishop

    • +3
      replicant replicant 11 февраля 2020 15:13 #

      У вас на сайте есть и более "страшная" проблема, которая намекает на возможное наличие ряда подобных "ляпов". Очевидно в силу ошибочной настройки оптимизации отдачи статики через nginx перестал быть доступен robots.txt из корня. Он есть тут http://rsfix.ru/wa-data/public..., но в корне его теперь нет (error 404).

      Либо ограничивайте кеширование nginx определенными каталогами типа /wa-data/, /wa-content/, /wa-apps/ и не давайте ему лезть в корень, либо отключите тип *.txt и заодно *.ico из списка статики, а то favicon.ico тоже буксует.

      Ещё резануло по глазам отсутствие оптимизации графики на сайте.


      После оптимизации фото крана вместо 575 кб занимает 4,25 кб.




      Подозреваю, что у вас какие-то системные комплексные проблемы накопились и дают о себе знать. Тут не что-то одно является причиной, а целая последовательность каких-то действий привела к текущему положению. Только вскрытие и изучение всего вашего проекта (проектов) от настроек сервера до оптимизации графики позволят выявить цепочку проблем и одну за одной последовательно их устранить. В частности выявить что такого есть у залогиненных пользователей, чего нет у гостя, что вызывает "торможение".

      Никакой волшебной кнопки под названием "сделать быстро" для вашего случая нет. Вам нужно искать спеца по оптимизации и отдавать проект на "прокачку". Очевидно путь на биржу экспертов.

  • 1
    Владимир Захаров 11 февраля 2020 15:52 #

    Сайт достался мне в наследство от прежнего админа. Вот что интересно. Те же самые страницы и админка нормально открываются, если подключить другую тему. Кроме того, на этой же теме нормально работает Сайт, Хаб и Блог, (и страницы, и админки этих приложений) в общем все, кроме Магазин. Да и Магазин работал три дня назад тоже нормально. Вот я и думаю, если сбросить настройки темы, наверняка все будет работать по-прежнему, а все остальное, что вы перечислили (кстати, спасибо) постепенно устранить в рабочем так, сказать, порядке.

    • +2
      replicant replicant 11 февраля 2020 17:12 #

      Сбрасывать настройки конечно можно, но это как-то радикально. Если настроек не очень много было сделано, то на всё ваша воля. Вам ведь восстанавливать их как было. Тема витрины Магазина к админке не имеет отношения. В админке она присутствует в виде исходного кода шаблонов и группы настроек из theme.xml. Возможно произошла череда каких-то совпадений, когда вам показалось, что какое-то одно событие создает проблемы, а на самом деле всё совсем не так. Не раз наблюдал, когда "в панике" люди бросались делать 100500 разных странных действий в админке, а потом и концов не найдешь что и как повлияло на общую картину.

      Я бы разбирал админку и витрину отдельно не мешая всё в кучу и не пытаясь искать между ними явную связь. На админку прежде всего влияют плагины и приложения, предназначенные для бекенда.

      • +1
        Владимир Захаров Владимир Захаров 12 февраля 2020 09:03 #
        Сбрасывать настройки конечно можно, но это как-то радикально. Если настроек не очень много было сделано, то на всё ваша воля.

        Более того, я не уверен, что это поможет. Я вообще думаю, что дело не в настройках, скорее, как вы сказали, дело в плагинах или в измененных шаблонах. Положение усугубляется тем, что после каждого изменения, нужно это проверять на сайте и в админке, то есть ждать более 30 секунд загрузки страницы и админки. Ну с плагинами-то я быстро могу разобраться - отключу сразу все, если будет нормально, то потом по одному буду подключать, пока не начнет снова тормозить. А вот как быть с шаблонами, стилями и скриптами?

  • 1

    Тормоза когда наблюдаются? При первом заходе в админку? Потом они пропадают как не в чем не бывало? Или на постоянной основе каждый раздел открывается 30 сек?

    • +1
      Владимир Захаров Владимир Захаров 12 февраля 2020 08:55 #

      Нет, не при первом заходе, это бы еще куда ни шло. Постоянные тормоза. И не только в админке, и сайт ведет себя так же под любым админом. А вот когда заходит незарегистрированный пользователь, все нормально. Что нужно удалить или добавить? 

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите