Плагин "Сбербанк" (платный)

Добрый день!

Перешел на SS8. После перехода перестали работать почти все плагины. В данной теме прошу подсказать кто сталкивался с такой проблемой - с плагином "Сбербанк" (платная версия). 

Плагин отрабатывает, платеж проходит. Но в конце выходит страница с такой ошибкой: 

Strict Standards: Only variables should be passed by reference in /home/rasty-nn/rasty-nn.ru/docs/wa-plugins/payment/sberbank/lib/sberbankPayment.class.php on line 243

Warning: Cannot modify header information - headers already sent by (output started at /home/rasty-nn/rasty-nn.ru/docs/wa-plugins/payment/sberbank/lib/sberbankPayment.class.php:243) in /home/rasty-nn/rasty-nn.ru/docs/wa-system/response/waResponse.class.php on line 225

Warning: Cannot modify header information - headers already sent by (output started at /home/rasty-nn/rasty-nn.ru/docs/wa-plugins/payment/sberbank/lib/sberbankPayment.class.php:243) in /home/rasty-nn/rasty-nn.ru/docs/wa-system/response/waResponse.class.php on line 225

В поддержке webasyst отправили к разработчику плагина, тот на хостинг, с хостинга обратно к разработчику сайта/плагина.

Спасибо!

2 ответа

  • 0
    Максим Креминский Webasyst 25 февраля 2019 10:46 #

    Попробуйте в первую очередь на хостинге выключить полностью вывод ошибок, например, в .htaccess:

    php_flag display_errors Off

  • 1
    АлексК 1 марта 2019 10:44 #

    Максим, в SS7 работало без ошибок.

    Хотелось бы понять что это за ошибка, а не игнорировать ее. В плагине она возникает или несовместимость плагина с SS8.. 

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите