Приложение не работает На рассмотрении

2

Версия 1.1.0.37290

При открытии приложения в админке - пустая страница с надписью ЗАГРУЗКА...

в консоли имеем ошибки

Uncaught SyntaxError: Unexpected identifier helpdesk-jquery.js?v1.1.0.37290:561

Uncaught TypeError: Cannot read property 'locale' of undefined ?action=loc&v=1.1.0.37290:1

Uncaught TypeError: Cannot set property 'helpdesk_controller' of undefined helpdesk.js?v1.1.0.37290:1

Uncaught TypeError: Cannot read property 'helpdesk_controller' of undefined (index):557

Uncaught TypeError: undefined is not a function (index):254

6 комментариев

  • +1

    Убедитесь, что у вас установлены все обновления, которые есть в инсталлере, в частности установлена последняя версия фреймворка.

  • +1

    Пока понятно только, что что-то не так с файлом wa-apps/helpdesk/js/compiled/helpdesk-jquery.js

    Это JS, склеенный автоматически из нескольких других файлов. Склейка происходит для оптимизации скорости загрузки. Если меняется один из составляющих файлов, compiled-версия создаётся заново.

    Могу предположить, что вносились правки в один из файлов JS.

    Включите в Инсталлере режим разработчика. Движок перестанет использовать compiled-скрипты и вставит все составляющие файлы по отдельности. Вы в консоли сможете понять, какой из них сломан. Если в дебаг-режиме всё нормально, удалите helpdesk-jquery.js. Он должен создаться без ошибок.

  • +1

    Все обновления установлены, изменения в файлы не вносились

    При включении дебаг режима все работает.

    Файл wa-apps/helpdesk/js/compiled/helpdesk-jquery.js удалил, он скомпилировался заново, но ошибка осталась прежней

    • +1

      Убедитесь, что ничего не застряло в кеше браузера.

      Если кеш не виноват... ну, надо препарировать ваш helpdesk-jquery.js. Выложите его пожалуйста куда-нибудь в сеть и дайте ссылку?

    • +1

      Видимо, виноват все же был кэш.

      Все заработало

      Добавить комментарий

      Чтобы добавить комментарий, зарегистрируйтесь или войдите