Не работает Workflow, почему?

Есть плагин, https://www.webasyst.ru/store/...

При удалении заказа не срабатывает Workflow этого плагина, не выводиться форма. Сам плагин включен и настроен. 

Исторически так сложилось, что в статусах немного наворотили, сейчас картина такая:


Обе кнопки, и "Удалить" и "Отмена" не показывают форму плагина. Даже внутри для дебага решил что-то записать в лог, но логи пустые, т.е. вызовы совсем не происходят.

Кто-то знает почему такое может происходить?

1 ответ

  • -1

    плагин работает

    • 0

      Спасибо, я знаю что плагин рабочий. Файлы фреймворка и приложений не правились, скриншоты событий я скинул, я так понимаю, что все должно работать, но почему-то не работает. Вот я и спрашиваю, есть ли у кого-то идеи почему? Может была подобная ситуация.

      • 0

        гадать можно сколько угодно, хочешь конкретики - выкладывай код

        • +1

          Код чего выкладывать? Фреймворка? Плагина? Там все стандартное. 

          Может кому-то пригодиться, проблема была в том, что не сработал install.php. После переустановки плагина все заработало.

          • +1

            Мой косяк, отвечал по последнему комменту и забыл про первый)

            По поводу твоего недовольства - ну как я могу угадать почему у тебя не работает код? Проверяй на версии без модификаций и делай принудительный install/uninstall/update. Я ожидаю от других разработчиков и тебя в частности что вы хотя бы понимаете основы этого говнокода, увы, это не всегда так и вы обижаетесь думая почему-то что я хочу вас обидеть/унизить - это не так. В общем, все классы и файлы не вызывающие напрямую класс плагина не приводят к вызову его install/uninstall/update методов. Если лень написать базовый unittest для плагинов или что-то типо того, то тупо заходи после установки на страницу настроек плагина - сработает install/uninstall.

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите