Обновление плагина Фиксированная стоимость до версии 1.1.1.6 не дает оформить заказ Принято

1

Shop-Script 7. Тема Default3. Оформление заказа в несколько шагов Контакты - Доставка - Подтверждение. После обновления плагина вообще перестало переходить с первого шага с контактной информацией на второй шаг к выбору способов доставки.

Если отключить из всех способов, тот, который через фиксированную стоимость, то второй шаг становится доступен.

На версии Shop-Script 6 все то же самое повторилось.

Снес плагин обновленный плагин. Быстро вернул старую версию. Всё сразу же снова заработало. Разбираться где и в чем ошибка детально не стал. Однако причина думается в этой обновке.

11 комментариев

  • +1
    Михаил Ушенин Михаил Ушенин Webasyst 21 декабря 2018 09:20 #

    Посмотрите, какие сообщения об ошибках появляются в PHP-логе и в консоли браузера в момент возникновения проблемы.

    • +1

      Для информации, не более:

      @Михаил Ушенин: подобная формулировка ответа может вызвать ощущение, что WA не попытался воспроизвести ситуацию, и просто запрашивает дополнительную информацию, мол изучите вопрос поплотнее, тогда рассмотрим. Добавили б к этому что попробовали, но все норм. Тогда и у ТС другое отношение сразу будет.

      @replicant: На последнем фреймворке с последней версией плагина с оформлением заказа с этим способом доставки навскидку все норм, проблем не замечено.

    • +1
      replicant replicant 21 декабря 2018 11:57 #

      Фреймворк у меня не последний (1.9.7.287). Забыл в теме про это указать. Но перед НГ обновляться пока не буду, потому что надо будет проверять и тестировать, а сейчас завал. Может быть в этом и причина, но тогда бы наверное  написали о несовместимости со старым фреймворком как в случае с плагином Курьер последней версии, который требует нового фреймворка.

      Лог пуст и чист. Консоль не проверял. Времени совсем было мало. Консоль гляну сегодня. Если что-то увижу, то сообщу.

      • +1
        Михаил Ушенин Михаил Ушенин Webasyst 21 декабря 2018 12:18 #


        Фреймворк у меня не последний

        Для работы любых компонентов фреймворк всегда должен быть последней версии. Обеспечивать работоспособность компонентов в расчёте на то, что кто-то не обновил фреймворк, нецелесообразно.

        Лог пуст и чист

        Нужно включить логирование ошибок PHP, повторить действие, которое заканчивается ошибкой, и показать записи в PHP-логе, которые появились в момент повторения ошибочного действия.

        • +2
          replicant replicant 21 декабря 2018 13:50 #

          Ну ок. Фреймворк пусть не последний, но сделайте хотя бы вот так как на скрине, чтобы не было вопросов. Если так не сделать, то предполагается, что плагин совместим с текущим фреймворком или это надо узнавать только опытным путем? Проблема получается в том, что вы даете обновления, зная о несовместимости или не зная, но предполагая. Короче, скриншот в помощь.



          Предполагаю и даже уверен в том (судя по комментарию выше), что на последнем фреймворке будет все ОК, но закройте, пожалуйста, возможность установки несовместимых обновлений для предыдущей версии фреймворка и вопросов никаких не будет. Я откачусь за 5 сек, имея хоть и небольшой, но опыт, а кто-то попадет и вынужден будет отключать способ доставки, если сообразит ещё это сделать.
          • +1
            PaKo PaKo 23 декабря 2018 00:26 #

            Такая же ситуация (( А вот как откатить теперь назад ? ((

            • +1
              replicant replicant 23 декабря 2018 10:10 #

              В данном случае достаточно просто заменить обратно файлы плагина /wa-plugins/shipping/flatrate теми, которые были откачены при обновлении в каталог /wa-data/protected/wa-installer/backup/wa-plugins/shipping/flatrate.

            • +1
              Dmitry - Dmitry - 21 января 2019 17:31 #

              Shop script 7.5.1.287 то же не дает возможности оформить заказ. С любыми настройками вывод надпись: 

              • Oops! We are sorry, but we can not ship this order to your selected destination. Checkout can not be completed.
              • +1
                Dmitry - Dmitry - 28 января 2019 22:39 #

                Какое-то решение этому будет?

                • +1
                  replicant replicant 29 января 2019 09:42 #

                  У вас другая проблема. Четко и ясно написано we can not ship this order to your selected destination.
                  Возможно страна, либо регион и/или город клиента не соответствуют настройкам плагина. Проверьте настройки Магазин - Доставка и данные клиента.

                  От себя добавлю, что на последнем фреймворке с SS6, SS7 и SS8 (т.е. с любыми версиями магазина)  плагин нормально работает.


                  • +1
                    Dmitry - Dmitry - 29 января 2019 14:03 #

                    Четко то четко, но не работае ни фига. Все уже перепробовал!

                    Добавить комментарий

                    Чтобы добавить комментарий, зарегистрируйтесь или войдите