Общая статистика используемых версий PHP (и др. софта) для разработчиков.

1

Сделать раздел (возможно скрытый и доступный только разработчикам, хотя и не понятно зачем его скрывать) в котором выводить общую статистику по ВСЕМ клиентам Webasyst про используемую ими версию PHP (и возможно другого софта: БД, ОС, что-то ещё)

Это будет очень актуально для разработчиков плагинов и приложений. Скажем если выяснится что уже 95% клиентов используют PHP версии 5.6 и выше - мы начнём делать новые плагины с указанием этой минимальной версии. Сейчас же ситуация непонятная и у фрейморка есть поддержка начиная с PHP 5.2, из-за чего разработчики вынуждены писать код на PHP бородатых лет дабы охватить максимальную аудиторию и бесконечно страдать от этого.

Неравнодушным разработчикам просьба поднять данную тему. Даешь PHP 5.6 а ещё лучше 7.1!

10 комментариев

  • +3
    Алексей Алексей Webasyst 7 декабря 2018 15:28 #

    Если нужна версия выше, указываете по формату https://developers.webasyst.ru...
    Облако пока 5.6, поэтому указание требований выше ограничит клиентов.

    • +1

      Я понимаю и знаю как указать нужную мне версию, в данном тикете я предложил идею собрать и показать статистику по платформам всех сайтов, не более того.

    • +2

      Давно уже делаю все плагины с требованием PHP 5.6

      Как только в облаке в след. году на 7 сменится, сменю требование и я

      Просто пока вы (или Вебассист) не начнёте требовать, пользователи останутся на том, что "и так уже много лет работает".

      Вебассисту это сделать сложнее. Но ему можно помочь :)

      И у них нет статистики особой по платформам

      • +1

        Так я и прошу её собрать и показать, не более того.

      • +1

        @Syrnik.com допустим ты делаешь все плагины мин.5.6, ва требует мин.5.2, 15-20% пользуется 5.2-5.5 значит, ты упускаешь 15-20% клиентов.

        5.2 на данный момент используется меньше чем на 2% в в сети.

        • +1

          Зато оставшиеся клиенты получают более лучший код :) . И быстрее.

          Это все равно, что ориентироваться на пользователей ie 10 во фронте.

        • +1

          @Syrnik.com т.е. ты будешь терять часть клиентов до тех под пока не изменится мин. версия  у фреймворка.

          • +1

            И после этого тоже будут клиенты теряться. Не все например 6 Shop-script обновили до 7. Что, теперь и их поддерживать?

            • +1
              Что, теперь и их поддерживать?

              Если бы была возможность ввести абонентскую плату на плагины/приложения, как я предлагал, и таких пользователей было бы достаточно, то конечно бы поддерживал.

              Я о том, что твои действия оказывают положительный эффект, но лучше бы это делалось на уровне фреймворка т.к. затронуло бы сразу все приложения/плагины.

              Добавить комментарий

              Чтобы добавить комментарий, зарегистрируйтесь или войдите