Поддержка версий Shop-Script

10

У меня предложение к команде Webasyst и разработчикам приложений, плагинов и тем. 

В описании к своим продуктам и обновлениям пишите, какой номер версии Shop-Script поддерживается! 6, 7 или 8. Я даже думаю, что это должно быть обязательным.

Например в этом месте:

9 комментариев

  • +1

    Это геморой для разработчика. Держать тестовые SS5, 6, 7, 8 .. 99. Все на них тестировать. К тому же будут случаться баги, которые не сможет заметить сам программист.. Все будут просто писать что SS8. Но идея правильная, чтобы потом претензии с SS 5 не писали в отзывах

    • +2

      Никакого геморроя. Объем тестирования увеличивается в большинстве случаев процентов на 10-15. А баги, которых не видит разработчик, есть всегда, даже если продукт ориентирован на одну версию. 

      Так что в свете платных обновлений SS и т.п. вполне разумное предложение.

      • +1

        Проверяете свои плагины на SS5 ? Наверное, нет )) Может даже думаете, что будут там работать...


        Наверное, многие пишут и тестируют плагины на последней версии SS. Потом проверяют на предпоследней и все на этом... 

        Вообще, актуальный вопрос. Как я понял плагины по доставкам будут работать либо на SS7, либо на SS8. Одновременная поддержка двух версий проблематична.. В обновлениях, вообще, нужно вшить проверку совместимости версий SS (если нет еще)

      • +1
        Antonio Antonio 25 ноября 2018 13:31 #

        Пример: Что бы сейчас обновится до Shop-Script 8 с 7 версии, мне надо написать письма разработчикам всех плагинов и тем, которые у меня есть и узнать про поддержку Shop-Script 8 или устанавливать на авось?

        • +1

          1. Сделать тестовый магазин и обновить его. Если сами не можете - к программисту 

          2. Проверить все что можно.

           3.1 Если норм (мало вероятно)  - сделать бэкап действующего магаза и обновиться. 

           3.2 Если не норм - пишите разработчикам, кто-то ответит, кто-то нет. Если плагины которые отказываются работать нужны - пишите программисту, чтобы он уже адаптировал под новый SS.

          По многим плагинам, думаю, разработчики и сами не в курсе, как они будут работать, и проверять не собираются (может уже чем-то другим занимаются, может у плагина мало продаж). Так что всем писать особого смыла нет. Просто вам не все ответят и в итоге будете гадать.. 

          • +1
            Antonio Antonio 25 ноября 2018 14:13 #

            Всё это понятно и я справлюсь.

            Разве плохо будет, что у плагина например будет надпись: Поддержка Shop-script 7, 8. Соответственно кто на шестой версии и не будут на него смотреть.

          • +2

            Лучше даже из инсталлера убрать такие плагины, которые не подерживаются. Я полностью согласен, что нужна такая информация. 

            Добавить комментарий

            Чтобы добавить комментарий, зарегистрируйтесь или войдите