Плагин "Курьер" и Shop-Script 6 Есть решение

Здравствуйте.

В плагине "Курьер" есть возможность указать желаемые дату и время доставки. Однако в описании сказано, что для этого функционала требуется Shop-Script версии 7.2.4.114 или выше. Наш магазин работает на SS 6 (6.3.0.44568), соответственно, желаемые дата и время не отображаются в карточке заказа в бекенде.

Возможно ли модифицировать плагин, чтобы желаемые дата и время показывались в магазине на Shop-Script 6? Кто-нибудь сталкивался с таким вопросом? Я буду признателен любой информации.

3 ответа

  • 2
    Syrnik.com Партнер-разработчик 16 марта 2018 13:48 # Решение

    Был кажется отдельный плагин ....

    А, вот он https://www.webasyst.ru/store/plugin/shop/sod/ С Shop-Script 6 должен работать

  • 4

    Не хочу обидеть, но странная тенденция.....смотреть на то, что доступно в новой версии продукта и вместо покупки обновления пытаться убедить кого-то, чтобы эту функцию добавили в старую версию.

    Есть и другая группа, которая купила обновления и старательно не замечает того, что было добавлено и возмущаются, что добавлены только функции, которые никому не нужны. "За что мы вам платим деньги!!!!"

    Мой совет один, обновляйтесь.....и всегда закладывайте в свои бизнес-расходы будущие обновления. Сидеть со старым корытом и представлять, что это автоматическая стиральная машинка не получится. Интернет-магазин - это ваш инструмент, и если вы работаете старым инструментом, то ваши конкуренты, которые пользуются современными инструментами будут расти, а вы деградировать. Я может быть слишком все гиперболизирую, но не принимайте это лично, я разговариваю не лично с вами, а со многими последователями подобных подходов ("вот тут можно изолентой перемотать, итак сойдет").

    • +1
      Win/D Win/D 16 марта 2018 14:44 #

      Я всеми руками за обновление, но руководство пока не хочет выделять на это деньги, убедить пока не удаётся. Именно поэтому я задал подобный вопрос.

  • 2

    Требования к версии приложения указаны не просто так: со стороны приложения реализованы интерфейсы отображения, редактирования и хранения нового вида данных. Плагин, грубо говоря, всего лишь говорит, что он может их спрашивать у покупателя, если приложение обучено показывать эти данные.

    Вам надо "модифицировать плагин", установив приложение актуальной версии. Ну или портировать код из нескольких десятков файлов актуальной версии приложения в вашу версию, но если вы готовы к этим работам, последующему тестированию и новым нюансам в работе.

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите