Ошбика при попытке обновления фреймворк webasyst на локалке Есть решение

2

Фреймворк установлен на локалке, на винде. Делал все по мануалу с вашего сайта. Всё работает, но обновиться не получается.
Отдельные приложения обновились без проблем. А основной фреймворк при обновлении выдает ошибку:

Фреймворк Вебасист (wa-system) Замена файлов обновленными Произошла ошибка Error on make backup for wa-system at wa-data/protected/wa-installer/backup/wa-system

перед тем как создавать новую тему я загуглил, нашел вот эту: https://support.webasyst.ru/13472/ne-udaetsya-obno...

Попробовал сделать все что в ней описано, но ничего не помогло.

Что делал:

  1. Закрыл все редакторы, которые могли бы лочить данную папку/файлы
  2. Проставил максимальные права на всё что только можно для всех юзеров
  3. Переименовал папку backup в backup1. По итогу новая папка backup создалась, но в ней никак не может создаться wa-system на который и ругается ошибка


3 комментария

  • +2
    Михаил Ушенин Михаил Ушенин Webasyst 3 ноября 2017 09:24 #

    Попробуйте выполнить обновление сразу после перезагрузки компьютера. Возможно, что всё-таки какой-то процесс блокирует файловую систему в вашем случае. И проверьте количество дискового пространства на диске, где установлен Webasyst.

  • +2
    Злой Димон Злой Димон 3 ноября 2017 11:17 #

    можно поставить прогу unlocker и с помощью неё посмотреть кто блокирует папку и разблокировать

  • +2
    Den Den 3 ноября 2017 14:29 #

    Да ребут помог, видимо что то лочило папку.

    Добавить комментарий

    Чтобы добавить комментарий, зарегистрируйтесь или войдите