Форма контактов Helpdesk не отправляет данные (ошибка http-https) На рассмотрении

3

Добрый день!

При попытке отправить данные через форму контактов helpdesk (добавлена на страницу с помощью {$wa->helpdesk->form(3)}) при нажатии кнопки отправить появляется кружок загрузки и крутится вечно. В Helpdesk данные при этом не уходят. Раньше такой проблемы не было, ничего не крутил (на странице контактов, в форме, настройках helpdesk), возможно после какого-то обновления перестало работать.

Консоль браузера показала, что ошибка в том, что пытается отправить через http форму, а сам сайт на https:

Поискал, где можно указать https в helpdesk, но не нашел. В настройках webasyst везде указан https.


4 комментария

  • +1
    Михаил Ушенин Михаил Ушенин Webasyst 10 августа 2017 15:22 #

    В тестовом аккаунте не удалось повторить такую ошибку. Напишите, сохранилась ли она ещё.

    Если сохранилась, то предлагаю вам воспользоваться услугой расширенной диагностикизаказать. В случае выявления ошибок в программных продуктах, разработанных нашей компанией, или наших инструкциях стоимость услуги будет возвращена в полном объеме.

  • +1
    Nikolai Nikolai 11 августа 2017 12:03 #

    Один сайт, в настройках инсталлятора и магазина указан адрес с https. Форму на сайт добавляют через {$wa->helpdesk->form(3)}, как и указано в информации по форме. Вероятно, проблема с тем, что данные передаются через http, а сайт на https, из-за этого браузер не дает выполняться такому скрипту. Т.е. почему-то неверно формируется код по form(3). Также в информации формы есть код iframe и в нем тоже стоит http вместо https.

    Заказал услугу расширенной диагностики, посмотрим, с чем это связано.

  • +1
    Nikolai Nikolai 10 августа 2017 21:39 #

    Проверил, да, сохранилась.

  • +1
    Михаил Ушенин Михаил Ушенин Webasyst 11 августа 2017 09:46 #

    Напишите подробнее, как устроены ваши сайты. Например, есть ли сайты-псевдонимы или ещё что-то необычное.

    Добавить комментарий

    Чтобы добавить комментарий, зарегистрируйтесь или войдите