Не работает Cron Не принято

1

Вот такая проблема, если запустить обновление через консоль VDS:

root@server~# /usr/bin/php -q /var/www/www-root/data/www/сайт.ru/cli.php shop yandexmarketPluginExport 357

PHP Warning: require_once(/wa-system/autoload/waAutoload.class.php): failed to open stream: No such file or directory in /var/www/www-root/data/www/сайт/wa-config/SystemConfig.class.php on line 3

PHP Fatal error: require_once(): Failed opening required '/wa-system/autoload/waAutoload.class.php' (include_path='.:/usr/share/php') in /var/www/www-root/data/www/сайт.ru/wa-config/SystemConfig.class.php on line 3

Если не указывать конкретный плагин, то работает:

root@server:~# /usr/bin/php -q /var/www/www-root/data/www/сайт.ru/cli.php shop

Use

/var/www/www-root/data/www/сайт.ru/cli.php APP CLASS PARAMS

3 комментария

  • +1

    У вас пропал файл wa-system/autoload/waAutoload.class.php. Попробуйте восстановить этот файл с содержимым, показанным по ссылке.

    • +1

      В том то и дело, что файл на месте и сайт работает нормально. Права на файл тоже в порядке. Но все равно сыпятся ошибки, не понятно в чем может быть дело. Файл пробовал заменить, на тот, что по ссылке выше, результата нет.

    • +1

      Проблема временно решилась тем, что в файле SystemConfig.class.php заменил переменную$_SERVER['DOCUMENT_ROOT'] на путь до файла. Все заработало, отсюда следует, что переменная $_SERVER['DOCUMENT_ROOT'] не поступает в файл, но я так понимаю, это уже не проблема фреймворка, а проблема настройки сервера. Но все же если есть мысли как это исправить, буду рад услышать.

      Добавить комментарий

      Чтобы добавить комментарий, зарегистрируйтесь или войдите