Ошибка JSON при ручном импорте CommerceML

Здравствуйте!

При попытке импорта вручную файла CommerceML выдает ошибку:

Unexpected token < in JSON at position 9; Ошибка #403

При этом, заголовок файла:

<?xml version="1.0" encoding="UTF-8"?>
<КоммерческаяИнформация xmlns="urn:1C.ru:commerceml_2" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" ВерсияСхемы="2.07" ДатаФормирования="2017-06-27T17:48:45">


Что не так с этим файлом?

10 ответов

  • 1

    Если проблема до сих пор не решена — по этому поводу имеет смысл отправить персональный запрос в службу технической поддержки из вашего Центра заказчика: https://www.webasyst.ru/my/

    • +1
      infomos infomos 1 июля 2017 17:58 #

      Спасибо, уже все решили. Почему-то такая ошибка выдается на одном хостинге, на другом отсутствует. Оба соответствуют всем требованиям.

      • +1
        Stuf Stuf 21 мая 2018 13:54 #

        Добрый день ) Не поделитесь как починили, такая же ошибка возникла.

        • +1
          infomos infomos 21 мая 2018 13:56 #

          В итоге, применение различных настроек на хостинге ни к чему не привело, сменили хостинг - все прошло без заминок. В итоге, правда, пришлось переехать на платный плагин обмена с 1С, т. к. стандартный функционал ничего не позволял сделать.
          Думаю, что если более вдумчиво покопаться, можно найти причину появления данной ошибки )

          • +2
            Stuf Stuf 21 мая 2018 18:49 #

            Да, у нас появилась как раз после переезда на новый )

            В общем помогло решение из этого поста, конкретно нам увеличение post_max_size. Можем кому еще поможет.

  • 1
    ИП Поповский Т.В. 19 января 2020 21:15 #

    Добрый день!

    Также возникла необходимость заново вручную импортировать свойства из xml-файла.

    За 2 года работы он вырос до 34мб.

    Помогло заархивировать его в zip-архив и в этом виде загрузить. Дальше все пошло!

  • 1

    Проблема с настройкой PHP может быть, надо увеличить:

    max_execution_time

    post_max_size

    upload_max_filesize

  • 1
    Антон Антонов 29 июля 2020 15:00 #

    Столкнулся с такой же проблемой на хостинге reg.ru / редактирование конфига php.ini не помогло.

    Подправил немного скрипт 1С (CommerceML), сделал возможность загрузить большой zip архив по FTP или через файл менеджер панели управления хостинга. 

    1. Заменить файл \wa-apps\shop\plugins\cml1c\lib\actions\backend\shopCml1cPluginBackendUpload.controller.php на этот (предварительно сделать копию оригинала)

    2. Загрузить архив с xml и картинками в /wa-cache/temp/shop/plugins/cml1c/ (имя файла должно быть 1c-export.zip) . Если таких директорий нет, то нужно создать. Структура архива должна быть такой 

    3. В админ панели сайта - 1С (CommerceML) выбираем Ручной обмен, далее выбираем любой файл и нажимаем Анализировать

    4. Первым выбираем import.xml, а потом offers.xml

  • 1
    Алексей Жаворонков 14 апреля 2021 02:18 #

    Увеличил

    max_input_nesting_level до 64000
    max_file_uploads  200000000

    Все заработало =)

    42 000 товаров. с картинками и характеристиками.

  • 1
    Алексей Жаворонков 3 декабря 2021 01:18 #

    Так же может помочь добавление параметра MaxRequestLen.

    Мы добавили строку MaxRequestLen 1073741824 в

    /etc/apache2/mods-enabled/fcgid.conf

    Стало :

    <IfModule mod_fcgid.c>
    FcgidConnectTimeout 20
    MaxRequestLen 1073741824
    <IfModule mod_mime.c>
    AddHandler fcgid-script .fcgi
    </IfModule>
    </IfModule>

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите