Не работает страница отписки от рассылки Есть решение

Доброго времени суток не могу исправить страница приложения не работает,

правила структуры на скрине

при обращении к странице /mailer/* вот такая ошибка


Empty module and/or action after parsing the URL "/mailer/" (frontend/).<br />Not found classes: mailerFrontendController, mailerFrontendAction, mailerFrontendActions code 404
/var/www/*****/data/www/**********.org/wa-system/controller/waFrontController.class.php (217)

## /var/www/*****/data/www/**********.org/wa-system/controller/waFrontController.class.php(217)
#0 /var/www/*****/data/www/**********.org/wa-system/controller/waFrontController.class.php(160): waFrontController->getController(NULL, 'frontend', NULL, false)
#1 /var/www/*****/data/www/**********.org/wa-system/controller/waFrontController.class.php(58): waFrontController->execute(NULL, 'frontend', NULL)
#2 /var/www/*****/data/www/**********.org/wa-system/waSystem.class.php(690): waFrontController->dispatch()
#3 /var/www/*****/data/www/**********.org/wa-system/waSystem.class.php(485): waSystem->dispatchFrontend('mailer/')
#4 /var/www/*****/data/www/**********.org/index.php(6): waSystem->dispatch()
#5 {main}

/var/www/*****/data/www/**********.org/wa-system/controller/waFrontController.class.php around line 217

212            if ($action && $try_default) {
   213                return $this->getController($plugin, $module, null, false, $class_names);
   214            }
   215   
   216            // Too bad. 404.
 >>217            throw new waException(sprintf('Empty module and/or action after parsing the URL "%s" (%s/%s).<br />Not found classes: %s', $this->system->getConfig()->getCurrentUrl(), $module, $action,implode(', ',$class_names)), 404);
   218        }
   219   
   220        /**
   221         * Helper for $this->execute()
   222         * Makes sense to override this in subclasses to add error handling, event dispatching, etc.

Request

array()

Params

array(
  'app' => 'mailer',
  'theme' => 'default',
  'theme_mobile' => 'default',
  'locale' => 'ru_RU',
)

Как исправить?




1 ответ

  • 1
    Antonio 20 апреля 2017 19:35 # Решение

    Надо проверить установлена ли рабочая тема оформления для приложения Рассылки в структуре сайта и сама тема оформления поддерживает Рассылки. Попробовать сменить тему для Рассылок.

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите