Выгрузка изображений на сайт при обмене с 1С.

Добрый день. Регулярно испытываем проблемы при выгрузке новых изображений при обмене 1с с сайтом.

Имеется 1С УТ 10.3

Изначально выгрузили каталог и все изображения встали как надо (соответствующая галочка в 1С установлена). Со временем появилась необходимость изменить изображения у некоторых товаров на новые. Делаем это так: на старое изображение ставится пометка на удаление, загружается новое изображение, помечаем его как "основное", делаем удаление помеченных объектов. При полной выгрузке на сайт старое изображение у товара (на сайте, конечно же) остается, новая картинка добавляется второй.

Тоже самое происходит, если хотим новую картинку сделать основной, а старую не удалять из карточки товара в 1с. Помечаем новое изображение как основное, выгружаем, а на сайте оно становится вторым, старая картинка остается основной.

Решаем проблему чисткой каталога wa-data/protected/shop/products и wa-data/public/shop/products + чистка таблицы с изображениями в БД, но это уже поднадоело.

Почему так происходит? Куда смотреть? Может кто-то сталкивался?

Спасибо.

2 ответа

  • 1
    Михаил Ушенин Webasyst 15 февраля 2017 15:33 #

    Ваше сообщение передали разработчикам. Похоже, что описанная вами возможность ещё не реализована в плагине. Если от разработчиков поступит дополнительная информация, мы добавим её здесь в комментариях.

    • +1
      Olejeg Bolduin Olejeg Bolduin 14 сентября 2017 10:00 #

      Решение было найдено?

    • +1
      UrbanVibe UrbanVibe 18 сентября 2017 19:01 #

      Здравствуйте, присоединюсь к данному вопросу.
      У меня 1С Розница, Сайт в "Облаке".
      В 1С, если у товара 1 фотография, то она успешно обновляется при выгрузке.
      Если товар содержит 2, 3, 4 и так далее, фотографии, то начинаются проблемы с их обновлением и удалением.
      ---
      Так например у товара было 3 фотографии, я удаляю из 1С: 2 и 3 фотографию, делаю выгрузку данных на сайт, по факту фото 2 и 3 должны удалиться с сайта, но этого не происходит.
      Так как товаров много, постоянно менять и отслеживать изменения на сайте не очень удобно!
      ----------------------------------------
      Попросите разработчиков, что бы в Плагине "1С (CommerceML)" сделали "Пункт с галочкой", что бы выбрав его можно было при выгрузке на сайт удалять ВСЕ фото с сайта, и добавлять актуальные.

    • +1
      jahrider jahrider 14 апреля 2018 12:42 #

      Михаил, похоже проблема до сих пор не решена? Или нужно делать дополнительные настройки в плагине? Столкнулся с такой же ситуацией.

      • +1
        UrbanVibe UrbanVibe 14 апреля 2018 12:57 #

        Я разговаривал с теми, кто КоммерсеМЛ плагин делает, они сказали что в рамках данного "инструмента синхронизации" нельзя сделать такую вещь.
        Последовал их совету, выход из ситуации такой: установил плагин "Массовое удаление изображений" для Вебасиста.
        Выбираю отдельные, либо все фотографии в списке товаров, жму удалить фото....
        Далее делаю свежую выгрузку из 1С и радуюсь ))).

  • 1
    Иван Петров 22 мая 2020 05:20 #

    Загрузка фоток
    &НаКлиенте
    Процедура ЗагрузитьФото(Команда)

    ИмяФайла = "";
    ПутьФайла = "";

    Если ПоместитьФайл(ПутьФайла, , ИмяФайла, Истина) = Истина Тогда

    Фото = ПутьФайла;
    УстановитьФото();

    КонецЕсли;

    КонецПроцедуры

    &НаСервере
    Процедура УстановитьФото()

    НовоеФото = Справочники.Файлы.СоздатьЭлемент();
    НовоеФото.Файл = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Фото));
    Фото = ПоместитьВоВременноеХранилище(НовоеФото.Файл.Получить());
    НовоеФото.Записать();
    Объект.Фото = НовоеФото.Ссылка;

    КонецПроцедуры

    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

    Фото = ПолучитьНавигационнуюСсылку(Объект.Фото, "Файл");
    Элементы.Фото.РазмерКартинки = РазмерКартинки.АвтоРазмер;

    КонецПроцедуры

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите